Hello Admin
Congrats on the new voting feature.
I don't know where this request falls but I would love to see a recoding of the Ajax naming convention. Currently the builder seems to simply add a sequence number to the word "select" when generating these references. This seems simple but it creates large discrepancies between component versions.
xmlajaxContext="demo.thirdusers.ajax.select11"
phpswitch($render)
{
case select11:
/* Ajax List : Demolist
* Called from: view:demoitem, layout:demoitem
*/
$model = $this->getModel();
Changing a single Ajax reference has the potential to ripple through the entire component, changing all the references. Therefore there is no such thing as a local update to a given view in an Ajax context; all changes have global scope.
I have found that tracking down an Ajax issue and resolving it only offers new challenges when moving to a new version of the same component. New effort must be mounted to find the new reference and apply the cure each time.
I would love to see the field name and maybe the "layout" used in generating these references. This way changes to a layout will be local to that layout and its end-point, about 3 files or so.
xmlajaxContext="demo.thirdusers.ajax.created_by"
Also, I could be wrong but I see no need to have a separate "created_by" routine for each view which instances the Author wizard. Only if the user called different values [username/name/email] will variations or separate routines be necessary. This applies to all other references which have duplicate routines. If a developer creates identical references, chances are they require the same data and the same routine can be used to service that need.
In the final analysis I don't know what is easy to change in the builder so I will leave it to your judgement. All I am saying is that there exist a need to prevent an Ajax modification on a single layout from changing the entire component.
Warm regards
vlemos