Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: [FIXED] Bug avec les couleurs

[FIXED] Bug avec les couleurs 17 Oct 2012 05:38 #4605

  • felichon
  • felichon's Avatar
  • Offline
  • Junior Member
  • Hello world :-)
  • Posts: 39
  • Thank you received: 7
  • Karma: 0
Hello,

Juste une remarque, j'ai mis la configuration en Jquery, avec toutes les options au maximum (Todo etc...) en version V2.5Beta, bref tout à fond...

(NOTE : J'ai remarqué qu'avec Mootool et le builder en Joomla!1.6, 1.7 et 2.5 cette erreur disparait)

Une erreur apparait quand on veux choisir une couleur, la boite de dialogue apparait bien, on peu choisir la couleur aucun soucis, mais on ne peu pas enregistrer le travail, la boite de saisie de couleur affiche l'erreur suivante :

* Incorrect value en rouge.

C'est une erreur facile a corriger, (en edition) il suffit d'ajouter un dièse (#) devant le code couleur sélectionné.

Je sais pas si ce feedback peu servir, mais bon voila, il faudrait rajouter ce dièse dans le code.

Amicalement.
Check out my extensions for Joomla! eliopro.fr
Last Edit: 19 Oct 2012 05:21 by admin.
The administrator has disabled public write access.

Re: Bug avec les couleurs 19 Oct 2012 05:21 #4652

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Chef
  • Posts: 3701
  • Thank you received: 972
  • Karma: 140
Corrigé.

Recharge la page.
Retourne dans les propriétés du champ.
Change le validator, et resélectionne 'couleur'

Cela devrait fonctionner.
Coding is now a piece of cake
The administrator has disabled public write access.
The following user(s) said Thank You: felichon

Re: Bug avec les couleurs 19 Oct 2012 07:01 #4656

  • felichon
  • felichon's Avatar
  • Offline
  • Junior Member
  • Hello world :-)
  • Posts: 39
  • Thank you received: 7
  • Karma: 0
Hello admin, B)

Oui, ça fonctionne très bien à présent. :cheer:

A des fins d'essais, je bricole un composant qui afficherai les mentions legales obligatoires des sites internet et société.

J'avais pour ça ajouté des donnée bidons, j'y ai mis une société fantoche dont le dirigeant serai TUX et la boite Linux open source.

La derniere fois que j'ai essayé tout fonctionnait bien. (il y a 3 jours)

J'ai supprimé la "Brique "Color" de ma table, puis j'en ai immédiatement remis une autre après avoir vidé la corbeille.

J'ai cliqué sur la Propriété au préalable de Color dans la liste du validator n'ai que le choix entre None ou Custom.

J'ai ensuite remplacé les champs dans les differents layout.

Lors du Run dans la sandbox j'ai eu ce message d'erreur :
JInstaller: :Install: Error SQL DB function failed with error number 1054
Unknown column '' in 'field list' SQL=INSERT INTO `[PREFIX]demo6334_societ` (`id`,`params`,`logo`,`raison_social`,`directeur`,`effectifs`,`capital`,`siren`,`siret`,`ape`,`date_de_cration`,`tva`,`cnil`,`published`,`ordering`,``,`essais`) VALUES (1,'','tux-1.png','Peinture Tux','Touxounet',4,'8.000.000 €','12315645648','7985656132','B-75145','2012-10-22','789451','753159',1,1,'#305c0e',3);
SQL =

INSERT INTO `#__demo6334_societ` (`id`,`params`,`logo`,`raison_social`,`directeur`,`effectifs`,`capital`,`siren`,`siret`,`ape`,`date_de_cration`,`tva`,`cnil`,`published`,`ordering`,``,`essais`)
VALUES
(1,'','tux-1.png','Peinture Tux','Touxounet',4,'8.000.000 €','12315645648','7985656132','B-75145','2012-10-22','789451','753159',1,1,'#305c0e',3);

Component Install: SQL error file DB function failed with error number 1054
Unknown column '' in 'field list' SQL=INSERT INTO `[PREFIX]demo6334_societ` (`id`,`params`,`logo`,`raison_social`,`directeur`,`effectifs`,`capital`,`siren`,`siret`,`ape`,`date_de_cration`,`tva`,`cnil`,`published`,`ordering`,``,`essais`) VALUES (1,'','tux-1.png','Peinture Tux','Touxounet',4,'8.000.000 €','12315645648','7985656132','B-75145','2012-10-22','789451','753159',1,1,'#305c0e',3);
SQL =

INSERT INTO `#__demo6334_societ` (`id`,`params`,`logo`,`raison_social`,`directeur`,`effectifs`,`capital`,`siren`,`siret`,`ape`,`date_de_cration`,`tva`,`cnil`,`published`,`ordering`,``,`essais`)
VALUES
(1,'','tux-1.png','Peinture Tux','Touxounet',4,'8.000.000 €','12315645648','7985656132','B-75145','2012-10-22','789451','753159',1,1,'#305c0e',3);

There was an error installing the package

Impossible d'acceder à la sand box, alor j'ai vidé les donnée contenu dans la base par un flush de la BD.

Maintenant ça fonctionne bien.

J'ai aussi remarqué qu'il était possible d'uploader des images dans la sandbox mais pas des fichiers.

- J'ai créé minuscule zip avec un fichier texte qui dit hello world. Malgré un réglage dans les options de téléchargement pour le zip je reçoit un message que ce type de fichier n'est pas possible en upload.

Voilà, voilà.

PS : beau travail pour les couleurs, t'a vite resolu le probleme.

@ +++
Check out my extensions for Joomla! eliopro.fr
Last Edit: 19 Oct 2012 07:04 by felichon.
The administrator has disabled public write access.

Re: Bug avec les couleurs 19 Oct 2012 07:16 #4657

  • JoomGuy
  • JoomGuy's Avatar
  • Offline
  • Moderator
  • Joomla Enthusiast, Lover of Cooking
  • Posts: 1115
  • Thank you received: 195
  • Karma: 68
Francais:
Salut à tous,

Je suis heureux que l'option flush données travaillé pour vous. La question était à cause d'un nom de domaine ne correspondent pas (probablement celle que vous avez supprimé et rajouté). Cela se produit lorsque les données à partir des données automatiquement sauvegardées inclut des champs (colonnes) qui ont changé dans les tables qui sont en cours de construction au sein de votre nouveau composant dans le bac à sable.

Votre ZIP upload doit travailler localement. Je crois que le bac à sable est probablement limitée à accepter les transferts de fichiers image uniquement pour des raisons de sécurité. Avez-vous essayé de l'utiliser dans un environnement de développement local? Il faut y travailler.

Espérons que cela fonctionne pour vous!

Gez

English:
Hi There,

I'm glad that the flush data option worked for you. The issue there was because of a mismatched field name (probably, the one that you deleted and re-added). This occurs when data from the automatically backed up data includes fields (columns) that have changed in the tables that are being built within your new component in the sandbox.

Your ZIP upload should work locally. I believe that the sandbox is probably limited to accepting uploads of image files only for security reasons. Have you tried using it in a local development environment? It should work there.

Hope this helps!

Gez
Need help with your Cook/Joomla Project? . PM me to find out what I can help with. NO time wasters please!!!
The administrator has disabled public write access.

Re: Bug avec les couleurs 19 Oct 2012 07:36 #4658

  • felichon
  • felichon's Avatar
  • Offline
  • Junior Member
  • Hello world :-)
  • Posts: 39
  • Thank you received: 7
  • Karma: 0
Hello audibleid,

Non, je ne m'entraine que dans la sandbox pour le moment, histoire de me faire la main avec le builder, il faut que je le maitrise avant de commencer à concevoir sérieusement un composant.

C'est en bonne voie en tout cas.

Dès que je maitriserai Cook correctement je fais prendre un plan chez vous sur au minimum 6 mois renouvellable, dans l'intervalle je m'entraine, car je ne suis pas encore tout à fait au point.

En ce moment je bute sur un problème ...

1.) A la partie Table du Builder : j'ai ajouté une Foreigne Key dans la table n°1 qui récupére les données de la table n°2, j'ai utilisé pour ça le Wizard. Jusque là tout va bien.

2.) J'ai ensuite voulu voir si les données apparaissent bien en Fronted, en ajoutant &cid=1 au lien et ça fonctionne sans souci. :huh:

3.) J'ai ensuite voulu faire la même chose avec une autre Foreigne Key dans la table n°1 qui récupére les données de la table n°3 mais bien que tout s'affiche en fronted sans donnée, quand je met &cid=1 seul les données de la table n°2 s'affichent, les données de la table n°3 sont invisible.

En fait, juste a des fins de testes je voulais voir si en fronted on pouvais afficher les données de plusieurs tables dans un seul layout. (Fly page)

Je dois faire quelque chose de traver car en fronted le label isus des foreyn key s'affiche mais pas le contenus qu'elle sont sencé affiché.

Je buche, je finirai bien par trouver :blink:

Amicalement.
Check out my extensions for Joomla! eliopro.fr
Last Edit: 19 Oct 2012 07:40 by felichon.
The administrator has disabled public write access.

Re: Bug avec les couleurs 19 Oct 2012 07:59 #4659

  • JoomGuy
  • JoomGuy's Avatar
  • Offline
  • Moderator
  • Joomla Enthusiast, Lover of Cooking
  • Posts: 1115
  • Thank you received: 195
  • Karma: 68
Francais
Désolé,

J'utilise google traduire ici et il ne fonctionne pas très bien sur votre dernier message.

Si je comprends bien, vous souhaitez continuer à utiliser le bac à sable jusqu'à ce que vous ayez une meilleure compréhension de comment tout fonctionne, c'est exact?

En outre, vous essayez de créer une vue qui affiche des données provenant de plusieurs tables, ils corrects?

C'est certainement possible - je fais ceci beaucoup en ce moment.

En ce qui concernant vos données est concerné, vous devriez essayer d'utiliser aussi peu de champs clés étrangères dans chaque tableau que possible. Cela permettra d'atteindre un ensemble plus normalisée des données et la base de données.

Le principe des bases de données, et ici, à cuisiner aussi, c'est que dans l'idéal, vous devriez être capable de traverser tous les objets (tables) pour obtenir des données à partir de n'importe quelle table dans une relation dans une requête, par exemple. Même si ce n'est pas directement la table jointe à la table principale. Donc, pour répondre à votre question, prenons un rapport 3 table à titre d'exemple:

Sections table - champs id, titre et alias
Categories table - id, titre, pseudonyme et section_id (sections.id)
Products table - id, titre, pseudonyme et category_id (categories.id)

Maintenant, lorsque vous accédez à un objet produit, soit dans une page de grille ou un objet, même si elle ne stocke pas le section_id, vous savez indirectement à partir du champ category_id ce que la section est en parcourant les tables.

Si vous utilisez une liste déroulante dans vos formulaires, vous pouvez ajouter automatiquement accès à cette situation en donnant à l'utilisateur la possibilité de sélectionner d'abord la section, puis sélectionnez les catégories de cette section seulement. Cet puis stocke uniquement les categories.id dans le domaine products.category_id.

J'espère que c'est ce que vous espérez réaliser!

Bonne chance,

Gez

English:
Sorry,

I'm using google translate here and it is not working very well on your last post.

If I understand correctly, you wish to continue using the sandbox until you have a better understanding of how everything works, correct?

Also, you are trying to create a view that displays data from multiple tables, correct?

This is definitely possible - I'm doing this lots at the moment.

As far as relating your data is concerned, you should try to use as few foreign key fields in each table as possible. This will achieve a more normalised data set and database.

The principle in databases, and here in cook too, is that ideally, you should be able to traverse all objects (tables) to get data from any table in a relationship in one query, for example. Even if it is not the table directly joined to the main table. So, in answer to your question, lets take a 3 table relationship as an example:

Sections table - id, title and alias fields
Categories table - id, title, alias and section_id (sections.id)
Products table - id, title, alias and category_id (categories.id)

Now when you access an product item, either in a grid or item page, even though it doesn't store the section_id, you know indirectly from the category_id field what the section is by traversing the tables.

If you use a combobox in your forms, you can automatically add access to this by giving the user the option to first select the section, then select the categories from that section only. This then only stores the categories.id in the products.category_id field.

I hope that this is what you're hoping to achieve!

Best of luck,

Gez
Need help with your Cook/Joomla Project? . PM me to find out what I can help with. NO time wasters please!!!
The administrator has disabled public write access.
The following user(s) said Thank You: admin

Re: Bug avec les couleurs 19 Oct 2012 08:04 #4660

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Chef
  • Posts: 3701
  • Thank you received: 972
  • Karma: 140
Merci Modo !

La traduction est très très bonne !!
K+
Coding is now a piece of cake
The administrator has disabled public write access.
The following user(s) said Thank You: JoomGuy

Re: Bug avec les couleurs 19 Oct 2012 08:09 #4661

  • JoomGuy
  • JoomGuy's Avatar
  • Offline
  • Moderator
  • Joomla Enthusiast, Lover of Cooking
  • Posts: 1115
  • Thank you received: 195
  • Karma: 68
@admin - google translate is awesome!

@felichon

Un peu plus explication...

Vous avez besoin de:
1. utiliser la propriété group_by dans les options du champ de la liste déroulante
2. sélectionnez le champ de la "rejoindre" Table de filtrer sur - dans ce cas, 'section' et dont le champ de la «section que vous souhaitez utiliser (sans doute son titre).

Ensuite, vous recevrez automatiquement filtrés par catégories de la section choisie dans la liste déroulante premier.

Sur votre page de grille ou élément pour vos produits (dans cet exemple), vous pouvez maintenant faire glisser tous les champs de toutes les tables liées à votre disposition. Cela peut être fait en élargissant les champs avec le signe '+'.

Espérons que cela aide!

Gez
Need help with your Cook/Joomla Project? . PM me to find out what I can help with. NO time wasters please!!!
The administrator has disabled public write access.

Re: Bug avec les couleurs 19 Oct 2012 08:12 #4662

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Chef
  • Posts: 3701
  • Thank you received: 972
  • Karma: 140
Eh modo, tu va te fatiguer comme çà.

Garde un peu d'énergie pour endurer dans le temps ;-)

Thank you so much.
Coding is now a piece of cake
The administrator has disabled public write access.
The following user(s) said Thank You: JoomGuy

Re: Bug avec les couleurs 19 Oct 2012 08:23 #4663

  • JoomGuy
  • JoomGuy's Avatar
  • Offline
  • Moderator
  • Joomla Enthusiast, Lover of Cooking
  • Posts: 1115
  • Thank you received: 195
  • Karma: 68
J'ai été très bien français à l'école mais j'ai honte de dire que je suis très, très rouillée maintenant près de 20 ans plus tard ... Je sais que les forums français sont prioritaires si juste voulu faire ma part pour aider un peu ici.

Puis-je suggérer que les francophones traduisent leurs requêtes en français à utiliser pour la recherche sur les forums anglais? Puis, en utilisant google translate (disponible directement sur la page en chrome au moins), la page peut automatiquement être retraduite en français.

Juste une suggestion et je sais que ce n'est pas idéal, mais il peut aider à répondre à vos questions plus rapidement ...

Bonne chance!

Gez
Need help with your Cook/Joomla Project? . PM me to find out what I can help with. NO time wasters please!!!
The administrator has disabled public write access.
The following user(s) said Thank You: felichon

Re: [FIXED] Bug avec les couleurs 19 Oct 2012 11:07 #4671

  • felichon
  • felichon's Avatar
  • Offline
  • Junior Member
  • Hello world :-)
  • Posts: 39
  • Thank you received: 7
  • Karma: 0
Merci audibleid,

Oui, je vais encore utiliser un petit peu le "bac à sable" le temps de bien comprendre comment fonctionne le builder Cook, après je vais souscrir un plan financier pour réelement développer.

Audibleid, ti a très bien tout expliqué et je vais essayer tout ce que tu me dis.

J'apprécie ton long tutoriel, tu t'es donné beaucoup de mal à l'écrire et a l'expliquer.

Je trouve que tu t'exprime bien en français. :cheer:

Amicalement.
Check out my extensions for Joomla! eliopro.fr
Last Edit: 19 Oct 2012 11:11 by felichon.
The administrator has disabled public write access.

Re: [FIXED] Bug avec les couleurs 19 Oct 2012 11:17 #4672

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Chef
  • Posts: 3701
  • Thank you received: 972
  • Karma: 140
@audibleid

Le forum international (ANGLAIS) est prioritaire, pas le français.

En tout cas merci encore.
Coding is now a piece of cake
The administrator has disabled public write access.
The following user(s) said Thank You: JoomGuy

Re: [FIXED] Bug avec les couleurs 19 Oct 2012 11:19 #4673

  • felichon
  • felichon's Avatar
  • Offline
  • Junior Member
  • Hello world :-)
  • Posts: 39
  • Thank you received: 7
  • Karma: 0
Je vais souvent sur le forum anglais, mais mon anglais est également "rouillé" alors j'utilise "Google Translate" mais la traduction est très approximative.

Mais bon, Google à le mérite d'éxister et ça aide quand même.
Check out my extensions for Joomla! eliopro.fr
Last Edit: 19 Oct 2012 11:20 by felichon.
The administrator has disabled public write access.
The following user(s) said Thank You: JoomGuy

Re: [FIXED] Bug avec les couleurs 19 Oct 2012 11:41 #4676

  • JoomGuy
  • JoomGuy's Avatar
  • Offline
  • Moderator
  • Joomla Enthusiast, Lover of Cooking
  • Posts: 1115
  • Thank you received: 195
  • Karma: 68
Oui, c'est vrai! quand j'écris en anglais à traduire en français, je suis toujours prudent d'utiliser «parfait» anglais afin que Google peut traduire de manière efficace.

Je suppose que, c'est la raison pour la traduction d'un message général dans une autre langue peut être très rude.

@ admin - pas de problème. A la fois - toujours heureux de vous aider!

Meilleurs voeux,

Gez
Need help with your Cook/Joomla Project? . PM me to find out what I can help with. NO time wasters please!!!
The administrator has disabled public write access.

Re: [FIXED] Bug avec les couleurs 23 Oct 2012 11:16 #4698

  • felichon
  • felichon's Avatar
  • Offline
  • Junior Member
  • Hello world :-)
  • Posts: 39
  • Thank you received: 7
  • Karma: 0
Hello,

Juste pour le fun je vien de tester les couleurs a nouveau, en version 2.5 Beta dans la sandbox sa fonctionne très bien, le problème est résolu.

En revanche ça bug cette fois avec l'ancienne version (1.6, 1.7 et 2.5) dans la sandbox.

Pareil, il faut rajouter le # devant pour corriger.

Finalement le problème c'est déplacé ailleur.
Check out my extensions for Joomla! eliopro.fr
Last Edit: 23 Oct 2012 11:18 by felichon.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.113 seconds

Get Started